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Course Overview 

 

Welcome Information Technology Services is happy to provide you with this training 

opportunity.  We hope that you enjoy it and the time you invest in participating is 

valuable to your work here at Massey University. 

 

Feedback Upon course completion please fill out the online ITS Course Evaluation form. 

Your feedback is confidential and the information you provide allows us to deliver 

relevant and high quality ITS training for staff and post grad students. 

 

Purpose To provide an introduction to Visio 2010. 

 

Learning 

outcomes 

By the end of this course you will be able to: 

 Understand the principles of flowcharts. 

 Use the Visio drawing environment. 

 Use various methods to create a connected diagram. 

 Work with shapes. 

 Format shapes and text. 

 Use views and visual elements. 

 Work with Windows. 

 Print Diagrams. 

 

Format Face to Face learning. 

 

Learning guide Please return printed material to the Trainer at the end of the session. 

ITS thanks you for considering the environment before printing. 

 

Help & 

information 
For more training on Visio please visit http://office.microsoft.com/en-

us/support/results.aspx?ctags=CH010372847. 

 

 

 

http://office.microsoft.com/en-us/support/results.aspx?ctags=CH010372847
http://office.microsoft.com/en-us/support/results.aspx?ctags=CH010372847
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Flowcharting Theory 

 
Overview In this overview we discuss the principles of Flowcharting  

 
Definition and 

Purpose 
Flowcharts are easy-to-understand diagrams that show how steps in a 

process fit together. The purpose of flowcharting is to minimize the 

complexity of following a method or process. 

 
Types of 

Flowcharts 
The Systems Chart – is also known as an overview flowchart. It does not 

present detail, but instead presents a top-down view. Then, the individual 

areas of detail may be expanded in the form of Flow Diagrams. Because the 

Systems Chart is an overview, only a few shapes are used and the more 

specific shapes are left for the Flow Diagram. 

 

Throughout the Systems Chart, references should be made to the 

appropriate Flow Diagrams. This could be done by page numbering or 

some other cataloguing system. If your charts are going to be used 

electronically then you can link a shape on a Systems Chart to its 

corresponding Flow Diagram (e.g. with hyperlinks). 

 

Flow Diagrams or Flowcharts – is where expanded detail needs to be 

presented. A greater variety of shapes may be used here. Typically there 

will be several Flowcharts per Systems Chart. 

 

 
 

 

Continued on next page 
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Flowcharting Theory, continued 

 
Basic Rules Because flowcharts are a graphical representation, their appearance is 

important. 

 

Before you begin make sure you understand what is to be flowcharted, and 

how you want it presented. 

 

Rules for Flowcharts 

 

 Page Layout – The first step in constructing your flowchart is deciding on 

your page specifications. 

 Consistency – Everybody who produces flowcharts must always use the 

same shapes to represent the same things. 

 Readability – Flowcharts are intended to clearly convey a complex 

process. Keep them simple – no more than three shapes across by seven 

down is a good rule. Break your chart onto another page if necessary. 

 Assumptions – Most flowcharts make assumptions about the knowledge 

of the person reading them. Are your assumptions reasonable? 

 

Continued on next page 
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Flowcharting Theory, continued 

 
Basic Shapes  

 
 

 

 

  

 It is implied that you are 

reading down the page. 

 No more than 7 items per 

page (otherwise it’s too 

difficult to read). 

 Text goes on the line. 

 Labelling with number if 

required. 
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Using Visio 

 
Backstage (File) 

View 
The Backstage or File tab view gives you access to all the different 

categories of templates that are available in Visio 2010. 

 

 

 
Stencils Using the Basic Flowchart template will open the Shapes window, which 

contains different stencils. Here we see stencils for More Shapes, Quick 

Shapes, Basic Flowchart Shapes and Cross-Functional Flowchart 

Shapes. 

 

 

 

Continued on next page 
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Using Visio, continued 

 
Adding 

Additional 

Stencils 

You can add additional shapes to your current stencil by clicking on More 

Shapes and selecting a shape from any of the major categories (i.e. 

Business, Engineering, Flowchart etc. …).  

 

To remove a stencil from the Shapes window, right click the stencil and 

select Close from the shortcut menu. 

 

 
 

The stencil can also be floated (by right clicking the stencil and selecting 

Float Window from the shortcut menu) and dragged to another part of the 

screen. 

 

 
The drawing 

window 
The drawing environment looks like this: 
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Creating Connected Diagrams 

 
Introduction In this section we will learn to work with Smart Shapes to create connected 

diagrams. 

 
Create a 

Connected 

Diagram 

To start creating a diagram, follow the steps below. 

 

Step Action 

1 Drag a shape from the collection on the left and drop it onto 

the drawing canvas on the right. 

 

Select either the Pointer  or the Connector 

 tool from the Ribbon. (Note: If you choose the 

Connector tool, a connector will be automatically drawn from 

the previously selected shape to the shape that you drag onto 

the screen.) 

 

 
 

We can see:  

 The sizing handles (blue squares). 

 A small rotation handle above. 

 Blue triangles which allow you to connect to other 

 shapes (hover you mouse over the object to see these). 

 

  

Continued on next page 
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Creating Connected Diagrams, continued 

 
Create a 

Connected 

Diagram, 

continued 

Step Action 

2 Drop a second shape onto the canvas and you will notice 

alignment and spacing guidelines (orange lines) appear. 

 

 

 
 

3 To replicate a shape on the canvas, click on it to select it, keep 

pressing the control key (Ctrl) on your keyboard (a little plus 

sign will appear above your cursor), and then drag the shape to 

another location. Release your left mouse button before 

releasing the Ctrl key. 

4 When a shape is selected in the stencil, clicking the blue 

triangle of a shape on the canvas will add the selected stencil 

shape to the diagram. The shape will also be properly aligned 

and spaced. 

 

 
 

5 Hover your cursor over the blue triangle and the top four 

shapes will be displayed. You can now select the appropriate 

top shape by moving your pointer over to it. This is known as 

Quick Select by Cursor Tip. 

 

 
 

 

  

Continued on next page 
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Creating Connected Diagrams, continued 

 
Using Auto 

Connect 

Click onto the canvas, and float over the diagram to see the available 

connections directions (blue arrows). 

 

 
 

To add the Database shape using auto connect, first add it to the top four 

connections. You can do this by dragging it into the top four positions of 

the stencil. 

 

 
 

Now you can use Quick Select to auto connect shapes, since the database 

shape will now be part of the top four Quick select shapes. 

 

 

Continued on next page 
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Creatring Connected Diagrams, continued 

 

 
Inserting 

between shapes 
To insert a shape between two existing shapes, drag the shape from the 

stencil and drop it (between the two shapes you want it inserted between), 

when you see the two red markers. 

 

 
 

Visio will then split the connector and place the shape between them. 
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Working with Shapes 

 

 
Introduction Often shapes or groups of shapes and flow lines (Connectors) will need to 

be copied, moved or deleted. Here we look at some tools that make drawing 

construction easier and the appearance better. 

 
Selecting 

Shapes/Objects 
Use the Pointer tool  to select objects on the drawing canvas to 

change format, delete, etc.  

 

To select a single shape click on it with the Pointer tool. 

 

To select several shapes, click on the first shape, hold down the Shift or 

Ctrl key, and then click on additional shapes. You can also click and drag 

an outline over all the shapes to be selected (Marquee method). When 

using the Marquee method, you have to ensure that the box that you click 

and drag encloses the shapes you want to select. 

 

Note: The first shape you selected has a bold pink outline. This is the 

dominant shape. Additional objects that are selected have a regular outline. 

 

 
Aligning and 

Positioning 

Shapes. 

First select more than one shape. 

 

To automatically adjust spacing and alignment, select Home > Auto Align 

& Space. 

 

 
 

To adjust positioning, 

Select Home > Position (Arrange group) 

 

 

 

 

Continued on next page 
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Working with Shapes, continued 

 
Deleting a 

shape 
To delete a shape, select the shape and then press the Delete key. 

Visio will delete the shape and remove the redundant connector 

automatically. Visio does not however automatically reduce the spacing to 

the next connected shape. 

 

 
 

 

 
Using Re-

Layout 
You can use Re-Layout to rearrange connected diagrams on the page. As 

your diagram becomes larger you may want to change its layout. Rather 

than dragging individual shapes and re-aligning them, you can use Re-

Layout to assist you. 

Click Design > Layout (group) > Re-Layout Page 

 

 
 

Continued on next page 
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Working with Shapes, continued 

 
Using Re-

Layout, 

continued 

As your pointer floats over an option Live Preview shows you how your 

diagram will look with that option selected. 

 

 
 

Note: You can manually configure the options for the re-layout of your 

diagram by selecting More Layout Options (see the above diagram for its 

location). 
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Formatting Shapes and Text 

 
Format the 

Shapes Fill and 

Shadow 

Right click the shape and from the shortcut menu select Format > Fill. 

Alternatively select Home > Shape (group) > Fill 

 
Formatting a 

line 
A connector is an intelligent line. Right click the line and from the shortcut 

menu select Format > Line. 

Alternatively select Home > Line (Shape group) > Line Options 

 
Formatting 

Shape Text 
The text tool, Home > Text (Tools group), inserts a shape without a fill and 

without a line. To add text to a shape, select the shape and begin typing.  

To format the text of a shape right click the shape and from the shortcut 

menu select Format > Text. 

 

Live preview can be enabled in Options to see what the text will look like 

before it is selected. 

 

If you want to control the position, size and rotation of text in a block 

without changing the block, first select the shape, then select the Text 

Block tool Home > Tools group. 

 

 
 

 

Below is an example of how the alignment of the text can change without 

changing the alignment of the shape. 
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Using Views and Visual Elements 

 
Introduction You may want to look at diagrams in very fine detail. There are varioius 

ways we can do this in Visio. 

 
Full Screen 

Mode 
Visio can be used as a presentation tool, without you having to import the 

diagram into PowerPoint. 

 

Select View > Full Screen or use the F5 shortcut key. 

 

In Full Screen mode, multipage diagrams with hyperlinks, navigation, and 

data access will still be functional. (i.e. you will be able to use all the 

elements of the diagram in Full Screen mode). 

 

To return to normal view press Esc or F5 again. 

 
Visual 

Elements 
To make working with Visio easier we can show and hide rulers, grids, 

page breaks and guides. 

 

Select View > Show (group) and make your selection. 

 

Guides help you to move and align shapes. To use a guide move to the edge 

of a ruler and drag down (for a horizontal guide), and across (for a vertical 

guide). 

 

 
 

 

Now you can drag your shapes so that they glue to the guide. Note the red 

glue boxes that appear when the shape comes into contact with the guide. 

Shapes can be glued to guides along the edges of the shape or through the 

central axis. 

 

Now move the guide and the glued objects will move with the guide. 

 

Continued on next page 
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Using Views and Visual Elements, continued 

 
Visual 

Elements, 

continued 

 

 
 

Note: Guides do not print and you can add as many guides as you want to. 

 
Task Panes There are four task panes in the View tab which can be shown or hidden. 

 

 
 

1. Shapes Pane Previously known as the stencil window. This pane 

 is used to create shapes. 

2. Shapes Data All the data associated with a shape. 

3. Pan & Zoom Normally shows in the lower right of your diagram. 

 This window gives you a bird’s eye view. You can 

 click and drag in the window to zoom in. The 

 selected area can be resized and dragged. 

4. Size and Position  Allows you to see information about the shape. It 

 also allows you to change those values. 

 

Continued on next page 
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Using Views and Visual Elements, continued 

 
Showing & 

Hiding Visual 

Aids 

There are three visual aids under View > Visual Aids (group) which you 

can select or disable. 

 

 
 

1. Dynamic Grid  The orange indicators which help align and space 

 shapes. 

2. AutConnect  The four blue triangles that appear when you 

 hover over a shape and allow you to auto connect 

 to another shape. 

3. Connection Points  The small blue axis that show where you can 

 connect to on a shape. In Visio 2010 these only 

 display as you move a connector closer to a 

 shape. 

 

 
Views – 

Shortcut Keys 
You can use these shortcuts to change views using the mouse and the 

keyboard. 

 

 

 

To Use the mouse  

Zoom In Ctrl + Shift + Left Click 

Zoom Out Ctrl + Shift + Right Click 

Zoom to Enlarge Ctrl + Shift + Drag 

Pan Image Ctrl + Shift +Right Drag 

Zoom In or Out Mouse Wheel 

Move Image Up or 

Down 

Ctrl + Mouse Wheel 

Page F5 
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Working with Windows 

 
Introduction You can work with more than one diagram in Visio at the same time. You 

can also open two views of the same diagram at the same time.  

 
Working with 

two different 

diagrams 

To work with two different diagrams at the same time. 

 

Step Action 

1 Open the first diagram in Visio as you would normally. 

2 With the first diagram open, click on the File tab and select 

Open. Select the 2
nd

 diagram and click on Open. 

3 Select View > Arrange All (Window group). 

4 Both diagrams will now be displayed at the same time. You 

can select which diagram you want to work on, by clicking it, 

or selecting View > Switch Windows (Window group) and 

selecting the diagram from the drop down list. 

 

 
 

  

 
Working with 

two views of the 

same diagram 

You may want to zoom in on different parts of the same diagram at the 

same time.  

 

Step Action 

1 Open the diagram you wish to work on. 

2 Select View > New Window (Window group) 

3 A new window of the same diagram will be displayed. 

4 Both views will now be displayed at the same time. You can 

select which view you want to alter, by clicking on it, or 

selecting View > Switch Windows (Window group) and 

selecting the diagram from the drop down list. 
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Printing Diagrams 

 
Introduction To print your Visio diagram, so that it fits onto one sheet of paper, there are 

two settings that need to be adjusted. 

 
Page Setup 

Options 
Follow the steps below to ensure that your diagram prints onto one page. 

 

 

Step Action 

1 Select Design > Page Setup (dialogue box launcher). 

 

 
 

2  Under Printer paper select the appropriate paper size from 

the drop down list. 

 

 Under Print zoom select the radio button for Fit to 1 

sheet(s) across, by 1 sheet(s) down. 

 

 
 

 

  

Continued on next page 
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Printing Diagrams, continued 

 
  

Step Action 

3 On the Page Size tab, select the radio button for Pre-defined 

size and change the selection to the correct options. 

 

 
 

Click OK. 

 

4 Select File > Print >Quick Print. 

  

Continued on next page 
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Printing Diagrams, continued 

 
Inserting 

Headers or 

Footers 

 

Step Action 

1 Select File > Print > Print 

Preview 

 

 

2 In the Preview group, select Header & Footer. 

 

 
3 In the Header & Footer dialogue box, select the options you 

want to appear in your header and footer. 

 

 
 

 

 

 


