Microsoft Excel II
Graphs and Charts
# Table of Contents

*All tips are based on Microsoft Office 2007.

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table of Contents</td>
<td>1</td>
</tr>
<tr>
<td>Sorting data</td>
<td>2</td>
</tr>
<tr>
<td>Microsoft Excel</td>
<td>2</td>
</tr>
<tr>
<td>Sort 1 column</td>
<td>2</td>
</tr>
<tr>
<td>Sort by 1 column</td>
<td>2</td>
</tr>
<tr>
<td>Sort by 2 or more columns</td>
<td>4</td>
</tr>
<tr>
<td>Filtering data</td>
<td>5</td>
</tr>
<tr>
<td>Creating a chart / graph</td>
<td>7</td>
</tr>
<tr>
<td>Choosing a Chart Type</td>
<td>7</td>
</tr>
<tr>
<td>e.g. Line Chart</td>
<td>7</td>
</tr>
<tr>
<td>Changing the data range</td>
<td>9</td>
</tr>
<tr>
<td>Adding a series</td>
<td>10</td>
</tr>
<tr>
<td>Adding a Chart title</td>
<td>12</td>
</tr>
<tr>
<td>Adding an axis title</td>
<td>13</td>
</tr>
<tr>
<td>Modifying a chart / graph</td>
<td>14</td>
</tr>
<tr>
<td>Names in chart / graph</td>
<td>14</td>
</tr>
<tr>
<td>Making the chart/graph bigger to view hidden labels</td>
<td>15</td>
</tr>
<tr>
<td>Making the font size smaller to show all labels</td>
<td>16</td>
</tr>
<tr>
<td>Formatting the line on a graph</td>
<td>16</td>
</tr>
<tr>
<td>Showing data values in charts/graphs</td>
<td>16</td>
</tr>
<tr>
<td>Changing display units in axes</td>
<td>17</td>
</tr>
<tr>
<td>Displaying equation/ on chart</td>
<td>19</td>
</tr>
<tr>
<td>And much more</td>
<td>22</td>
</tr>
<tr>
<td>Example Questions</td>
<td>23</td>
</tr>
</tbody>
</table>
Sorting data

Microsoft Excel

Sort 1 column
1. Click any cell > Click on Sort & Filter > Sort A to Z or Sort Z to A button

<table>
<thead>
<tr>
<th>A</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
</tbody>
</table>

2. Sorted (e.g., Ascending order)

<table>
<thead>
<tr>
<th>A</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
</tbody>
</table>

Sort by 1 column
You have multiple columns and wish to sort by a particular column.

1. Select any cell in the column that you wish to sort by

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Elephant</td>
<td>10 Banana</td>
</tr>
<tr>
<td>2</td>
<td>Monkey</td>
<td>52 Apple</td>
</tr>
<tr>
<td>3</td>
<td>Chicken</td>
<td>1978 Orange</td>
</tr>
<tr>
<td>4</td>
<td>Horse</td>
<td>823 Lemon</td>
</tr>
<tr>
<td>5</td>
<td>Bird</td>
<td>1 Kiwi Fruit</td>
</tr>
</tbody>
</table>

2. Click on Sort & Filter > Sort A to Z or Sort Z to A button.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Bird</td>
<td>1 Kiwi Fruit</td>
</tr>
<tr>
<td>2</td>
<td>Chicken</td>
<td>1978 Orange</td>
</tr>
<tr>
<td>3</td>
<td>Elephant</td>
<td>10 Banana</td>
</tr>
<tr>
<td>4</td>
<td>Horse</td>
<td>823 Lemon</td>
</tr>
<tr>
<td>5</td>
<td>Monkey</td>
<td>52 Apple</td>
</tr>
</tbody>
</table>

Tip
You don’t need to highlight the entire column.
Tip: WARNING!
Be careful when you perform sorting. DO NOT highlight the whole column when sorting. Otherwise, your data can get mixed up easily. The Sort Warning message comes up when you highlight the column. Read the message carefully, or click Cancel to start again.

When you highlight the entire column and sort it, your sorting result is as below. For instance, column C was highlighted and was sorted ascending order.

This option enables you to do the same sorting as above.

This option sorts one single column only and ignores the rest of the data, i.e., when you have multiple columns next to each other, non-highlighted columns will stay as they are. Only the data in the highlighted column will be sorted. After sorting, the other corresponding row data won't be sorted so your data would become incorrect information.

When you select the entire column, you are defining the area to be sorted. It is not to be used as sort by.

When you highlight the entire column and sort it, your sorting result is as below. For instance, column C was highlighted and was sorted ascending order.

### Before sorting

<table>
<thead>
<tr>
<th></th>
<th>CustId</th>
<th>Firstname</th>
<th>Lastname</th>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>102</td>
<td>Nora</td>
<td>Pulaski</td>
<td>193 Mendez Vista</td>
</tr>
<tr>
<td>2</td>
<td>103</td>
<td>Alan</td>
<td>Pox</td>
<td>933 Placentia N</td>
</tr>
<tr>
<td>3</td>
<td>104</td>
<td>Yvonne</td>
<td>Andert</td>
<td>01 E Orange</td>
</tr>
<tr>
<td>4</td>
<td>105</td>
<td>Castin</td>
<td>May</td>
<td>8033 W Pumkins</td>
</tr>
<tr>
<td>5</td>
<td>113</td>
<td>Nora</td>
<td>Albert</td>
<td>193 La Jolla</td>
</tr>
<tr>
<td>6</td>
<td>114</td>
<td>Heather</td>
<td>Place</td>
<td>313 W Farm</td>
</tr>
<tr>
<td>7</td>
<td>115</td>
<td>Tom</td>
<td>Snyder</td>
<td>103 N Aloha</td>
</tr>
<tr>
<td>8</td>
<td>116 H. R.</td>
<td>Baker</td>
<td></td>
<td>331 Hidden St</td>
</tr>
<tr>
<td>9</td>
<td>121</td>
<td>Singh</td>
<td>Herman</td>
<td>91 Division St #36</td>
</tr>
<tr>
<td>10</td>
<td>122</td>
<td>Lorenzo</td>
<td>Wilson</td>
<td>3 Evergreen Plaza</td>
</tr>
<tr>
<td>11</td>
<td>123</td>
<td>Alaozo</td>
<td>Lu</td>
<td>98 Cherry</td>
</tr>
<tr>
<td>12</td>
<td>127</td>
<td>Don</td>
<td>Ohun</td>
<td>77 Federal Ave S</td>
</tr>
<tr>
<td>13</td>
<td>128</td>
<td>George</td>
<td>Wilson</td>
<td>333 Hoden St</td>
</tr>
<tr>
<td>14</td>
<td>129</td>
<td>Huddle</td>
<td>Perry</td>
<td>3113 W 3th</td>
</tr>
<tr>
<td>15</td>
<td>130</td>
<td>Andrews</td>
<td>Kupke</td>
<td>933 331th N #31</td>
</tr>
<tr>
<td>16</td>
<td>131</td>
<td>Chris</td>
<td>Butler</td>
<td>67 White Street</td>
</tr>
<tr>
<td>17</td>
<td>132</td>
<td>John</td>
<td>Neehoff</td>
<td>5997 Pines Lane</td>
</tr>
<tr>
<td>18</td>
<td>133</td>
<td>George</td>
<td>Lyman</td>
<td>599 East Westhoun</td>
</tr>
<tr>
<td>19</td>
<td>134</td>
<td>Erickson</td>
<td>Cooke</td>
<td>5700 Certified Way</td>
</tr>
<tr>
<td>20</td>
<td>135</td>
<td>Alexander</td>
<td>Campbell</td>
<td>5998 Accountant W</td>
</tr>
<tr>
<td>21</td>
<td>136</td>
<td>Ellis</td>
<td>Lock</td>
<td>75 Pyle Street</td>
</tr>
<tr>
<td>22</td>
<td>137</td>
<td>David</td>
<td>Geysta</td>
<td>88 East Westhoun</td>
</tr>
<tr>
<td>23</td>
<td>138</td>
<td>David</td>
<td>Mitchell</td>
<td>8653 Pug Drive</td>
</tr>
<tr>
<td>24</td>
<td>146</td>
<td>Bob</td>
<td>Lock</td>
<td>894 Greg Pud</td>
</tr>
<tr>
<td>25</td>
<td>147</td>
<td>Arthur</td>
<td>Geysta</td>
<td>864 Gregory Road</td>
</tr>
<tr>
<td>26</td>
<td>152</td>
<td>Paul</td>
<td>Lakeland</td>
<td>208 Certified Way</td>
</tr>
<tr>
<td>27</td>
<td>151</td>
<td>William</td>
<td>Cooke</td>
<td>1236 Bluffside Pd</td>
</tr>
<tr>
<td>28</td>
<td>152</td>
<td>Wendy</td>
<td>Campbell</td>
<td>12397 Pines Lane</td>
</tr>
</tbody>
</table>

### After sorting

<table>
<thead>
<tr>
<th></th>
<th>CustId</th>
<th>Firstname</th>
<th>Lastname</th>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>113</td>
<td>Nora</td>
<td>Albert</td>
<td>193 La Jolla</td>
</tr>
<tr>
<td>2</td>
<td>104</td>
<td>Yvonne</td>
<td>Andert</td>
<td>01 E Orange</td>
</tr>
<tr>
<td>3</td>
<td>116 H. R.</td>
<td>Baker</td>
<td></td>
<td>331 Hidden St</td>
</tr>
<tr>
<td>4</td>
<td>121</td>
<td>Singh</td>
<td>Herman</td>
<td>91 Division St #36</td>
</tr>
<tr>
<td>5</td>
<td>122</td>
<td>Lorenzo</td>
<td>Wilson</td>
<td>3 Evergreen Plaza</td>
</tr>
<tr>
<td>6</td>
<td>123</td>
<td>Alaozo</td>
<td>Lu</td>
<td>98 Cherry</td>
</tr>
<tr>
<td>7</td>
<td>127</td>
<td>Don</td>
<td>Ohun</td>
<td>77 Federal Ave S</td>
</tr>
<tr>
<td>8</td>
<td>128</td>
<td>George</td>
<td>Wilson</td>
<td>333 Hoden St</td>
</tr>
<tr>
<td>9</td>
<td>129</td>
<td>Huddle</td>
<td>Perry</td>
<td>3113 W 3th</td>
</tr>
<tr>
<td>10</td>
<td>130</td>
<td>Andrews</td>
<td>Kupke</td>
<td>933 331th N #31</td>
</tr>
<tr>
<td>11</td>
<td>131</td>
<td>Chris</td>
<td>Butler</td>
<td>67 White Street</td>
</tr>
<tr>
<td>12</td>
<td>132</td>
<td>John</td>
<td>Neehoff</td>
<td>5997 Pines Lane</td>
</tr>
<tr>
<td>13</td>
<td>133</td>
<td>George</td>
<td>Lyman</td>
<td>599 East Westhoun</td>
</tr>
<tr>
<td>14</td>
<td>134</td>
<td>Erickson</td>
<td>Cooke</td>
<td>5700 Certified Way</td>
</tr>
<tr>
<td>15</td>
<td>135</td>
<td>Alexander</td>
<td>Campbell</td>
<td>5998 Accountant W</td>
</tr>
<tr>
<td>16</td>
<td>136</td>
<td>Ellis</td>
<td>Lock</td>
<td>75 Pyle Street</td>
</tr>
<tr>
<td>17</td>
<td>137</td>
<td>David</td>
<td>Geysta</td>
<td>88 East Westhoun</td>
</tr>
<tr>
<td>18</td>
<td>138</td>
<td>David</td>
<td>Mitchell</td>
<td>8653 Pug Drive</td>
</tr>
<tr>
<td>19</td>
<td>146</td>
<td>Bob</td>
<td>Lock</td>
<td>894 Greg Pud</td>
</tr>
<tr>
<td>20</td>
<td>147</td>
<td>Arthur</td>
<td>Geysta</td>
<td>864 Gregory Road</td>
</tr>
<tr>
<td>21</td>
<td>152</td>
<td>Paul</td>
<td>Lakeland</td>
<td>208 Certified Way</td>
</tr>
<tr>
<td>22</td>
<td>151</td>
<td>William</td>
<td>Cooke</td>
<td>1236 Bluffside Pd</td>
</tr>
<tr>
<td>23</td>
<td>152</td>
<td>Wendy</td>
<td>Campbell</td>
<td>12397 Pines Lane</td>
</tr>
</tbody>
</table>

The Last Name column is sorted in alphabetical order.
Sort by 2 or more columns
You can specify as many columns as required

1. Click any data that you wish to sort by a few columns

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CustId</td>
<td>Firstname</td>
<td>Lastname</td>
<td>Address</td>
</tr>
<tr>
<td>2</td>
<td>113</td>
<td>Norm</td>
<td>Albert</td>
<td>131 La Jolla</td>
</tr>
<tr>
<td>3</td>
<td>104</td>
<td>Yvonne</td>
<td>Anderson</td>
<td>01 E Orange</td>
</tr>
<tr>
<td>4</td>
<td>115</td>
<td>H R</td>
<td>Under</td>
<td>021 Hilltop Be</td>
</tr>
<tr>
<td>5</td>
<td>131</td>
<td>Chris</td>
<td>Butler</td>
<td>57 White Street</td>
</tr>
<tr>
<td>6</td>
<td>135</td>
<td>Alexander</td>
<td>Campbell</td>
<td>50786 Accountant Way</td>
</tr>
<tr>
<td>7</td>
<td>152</td>
<td>Wendy</td>
<td>Campbell</td>
<td>12397 Flores Lane</td>
</tr>
</tbody>
</table>

2. **Sort & Filter > Custom Sort...**

3. The following window will open,

- Adds an additional level to sort by
- Deletes the selected level
- Makes a copy of the selected level and the options selected
- Moves the selected level up or down

4. Click the **OK** button. Your data will be sorted accordingly.

Troubleshooting
When your mouse cursor was in an empty cell, and was outside of the data area, the following error message will appear. You cannot perform sorting.
Filtering data

Filtering allows you to display only data that meets certain criteria. (e.g., only display the exams held in AH1 on 13-Jun, AM):

- Click the column or columns that contain the data you wish to filter
- On the Home tab, click on Sort & Filter
- Click the Filter button

- Click the Arrow at the bottom of the first row cell

- Un-tick the root check box (i.e. 2008)

- Click the date you wish to Filter (i.e. 13)
• Click OK

• Repeat the above steps for other criteria (i.e. am/pm, location)

• Done!
Creating a chart / graph

Choosing a Chart Type

There are many chart types that you can choose. It depends on how you wish to present your data.

**Bar, Column**
- Displays comparisons between independent data values

**Pie**
- Shows the relative size of the parts to a whole

**Line**
- Shows a trend over time of a series of data values

**XY (scatter)**
- Shows the relationship between two set of data points

**Doughnut**
- Shows the contribution of each part to a whole at outer edge

**Cone, Cylinder, Pyramid**
- Displays and compares data represented by each cone

**Bubble**
- A scatter chart showing relationships between sets of data

**Radar**
- Illustrates data change relative to a central point

**Stock**
- Displays low, high, open, and close values for stock prices

**Surface**
- Depicts relationships among large volumes of data

**Area**
- Shows size of change over time

**Microsoft Excel**

There are many chart types that you can choose but the line graph has been chosen as an example here. It depends on how you wish to present your data, and then the chart type changes.

Tip: It is easier to create a chart/graph if your data is nicely organised. Also, analyse your data to see which data refers to which series and axis. Have a quick brainstorm first.

**e.g. Line Chart**

1. Highlight data area to be graphed

2. Click **Insert**

3. Click the chart type (eg. Column graph) and sub chart type
4. The chart is created

Swap the data over the axis, data being charted on the X axis will move to the Y axis and vice versa.

1. Select the chart you wish to edit
2. Click on **Design** under chart tools > **Switch Row/Column**

The axis data is changed around
Changing the data range

Change the data range for a chart that has already been created

1. Select the chart you wish to change the data range for
2. Click on Design under Chart Tools > Select Data
3. The Select Data Source window opens
4. Click on the **Collapse Dialog** button at the right end of the **Chart Data range** box, this will temporarily shrink the dialog window, you can then re-highlight the data again.

**Adding a series**

5. Select the chart you wish to add a series to,

6. Click on **Select Data** under Chart Tools

7. Click on **Add**

8. Type a series name in the **Name** box e.g. *Dunedin (or Click on the cell with the name in it e.g. A5)*

9. Click on the **Collapse Dialog** button of the **Values**

10. Highlight data for the series **without any headings**,
11. Select the chart you wish to add a category to, click on **Design** under Chart Tools > **Select Data**

12. Click on **OK**

13. The series has been added, click on **OK**

14. Done!
Adding a Chart title

1. Select the chart you wish to edit

2. Click on **Layout > Chart Title**

3. From the Chart Title options, choose the appropriate positioning (**Centered Overlay** or **Above Chart**) for your title.

4. The title is added to your chart. Select the title box and type in the text for your title.

If your chart becomes uncountable, you can start creating a chart from scratch and highlight exact data that you wish to add to a series.

You can also take time to think about how you are going to structure the chart/graph.

This way can be also helpful if the values you wish to add into the chart are not sequential in cells, and you have to select data from different row locations.
Adding an axis title

1. Select the chart you wish to add axis titles to

2. Layout > Axis Titles > Choose from;
   a. Primary Horizontal Axis Title
      • None
      • Title Below Axis
   b. Vertical Axis Title
      • None
      • Rotated title
      • Vertical Title
      • Horizontal Title

3. Once the title is inserted you can click on it like a normal text box to edit it

4. Done!
Modifying a chart / graph

Names in chart / graph
The Chart Tool tabs appear when you select any part of the chart. Knowing the names in a chart / graph is useful when you modify the chart / graph.

Note: The Chart Tool tabs are only visible when you have a chart or part of a chart selected.

Tip
For example, when you wish to select Value Axis to modify your chart, click the drop list under (Chart Tools) Layout > Current Selection. This may be easier to select it rather than trying to click in the right spot on the chart / graph.
All the steps that you have gone through creating a chart/graph on page 2, you can go back to after you have finished creating your graph.

RIGHT click on the chart area. (Don’t click on the actual chart/graph. Check under Layout > Current Selection to see the selected object.)

**Step 1:** Choosing chart type, custom type, bar graph, line graph, scatter etc...

**Step 2:** Selecting data range, series name, series value, category (x) label etc...

**Step 3:** Chart location

**Step 4:** Change background fill, border colours, border styles, shadow effects and 3-D format

**Making the chart/graph bigger to view hidden labels**

Select the chart (click on any white part of the chart box so that square black boxes will appear at the corners) and drag the box out when the mouse pointer becomes “↔” on the corner. Some hidden labels will appear.
Making the font size smaller to show all labels

Right Click on the label > Font… > Choose smaller font size > Click OK.

Formatting the line on a graph

1. Right click on the line of a line graph > Click Format data series

2. Choose from the appropriate category, the most commonly used options are listed below

- Change the axis the series is plotted on
- Change the colour of the selected line
- Change the colour / gradient of the selected line
- Add / edit a shadow effect to the series lines
**Showing data values in charts/graphs**

Right click on the line > Click **Add Data Labels**

**Changing display units in axes**

For charts in which the figures contain many zeros, you can format the axis to abbreviate the figures. This will make the chart less cluttered.

Too many zeros makes it harder to read

1. One click on the Y axis labels (Square dots will appear at the both ends of the Y axis) > **Right** click on a label > **Format Axis**
2. Change the **Display units** on the **Axis options** tab to **Thousands**

3. Click on the **Number** tab, Change the **Decimal places** to **0** > Click **Close**

4. **Done!**
Adding trend line

- Click on the chart
- Layout Tab > Analysis group > Trendline
- Choose the type of trendline (i.e., Exponential Trendline)

Done
- Trendline Options > Tick on Display equation on chart / Display R-squared value on chart > Click Close

- Done
Dwellings Median Price

$y = 108790e^{0.107x}$

$R^2 = 0.9167$
There are much more functions under Chart Tools, they are waiting for you to explore.

- **Within the Design tab** you can control the chart type, layout, styles, and location.

- **Within the Layout tab** you can control inserting pictures, shapes and text boxes, labels, axes, background, and analysis.

- **Within the Format tab** you can modify shape styles, word styles and size of the chart.
Example Questions

**MS Excel 2010 Level Two Course Exercise Sheet**

**Question 1**

Q1.1
- Open Q1.xlsx
- Sort the exam timetable by following order:
  
  Exam Date > am/pm > Location > Code

Q1.2
- Find exams held on 14\textsuperscript{th} June, am in SSLB3

**Question 2**

Q2.1
Open **Q2&3.xlsx**
Choose **Total Sales** work sheet
Create a pie chart of total sales of July, 2008 cross all regions

Q2.2
Choose **days to sell** worksheet
Create a line chart of **days to sell** in last ten years for Northland and Taranaki

**Question 3**

Q3.1
Open **Q2&3.xlsx**
Choose **Median Price** work sheet
Create a column chart of the media price of Northland in 10 years
Change the display unit to thousands.
Add a linear trend line of the median price

Q3.2
Choose **Median Price vs. Total Sales** worksheet
Re-Create the chart below (create a chart with two Y axis.)

![Chart](chart.png)